Page tree
Skip to end of metadata
Go to start of metadata

Crucible 업그레이드 가이드



이 페이지는 Crucible의 새 버전으로 업그레이드하는 방법을 설명합니다. 우리는  강력하게 추천합니다  아래의 단계를 수행하여 Crucible를 업데이트하는 것이.

참고 사항 :

  • 이 업데이트 프로세스는  전체 업그레이드를 수행 하지  않지만 새로운 버전의 Crucible을 새로운 설치 디렉터리에 설치합니다. 새로운 Crucible은 기존 Crucible 홈 디렉토리와 외부 데이터베이스를 사용합니다.
  • 프로덕션 환경의 경우 프로덕션 환경에 배포하기 전에 QA 서버에서 Crucible 업데이트를 테스트하는 것이 좋습니다.
  • Crucible의 이전 버전에서 최신 버전으로 업데이트 할 수 있습니다.

Crucible을 마이그레이션하고 업그레이드하는 경우 Fisheye / Crucible 마이그레이션 및 업그레이드를 참조하십시오  .


1. 업그레이드 노트 검토

 Crucible의 각 버전에 대한이 페이지에서 특정 업그레이드 노트 가 있습니다  

Crucible의 현재 버전과 업그레이드 할 버전 사이의 각 버전에 대한 관련 섹션을 읽어야합니다.

2. Crucible 데이터 백업

위로까지  전체  Crucible 예 (참조  백업 및 Crucible 데이터를 복원 ) :

  • Admin 인터페이스를 통해 Crucible 인스턴스를 백업하는 경우 '포함'확인란 (예 : 플러그인, 템플릿, 업로드, SQL 데이터베이스 등)을 모두 선택하십시오.
  • 명령 줄 인터페이스를 사용하여 Crucible 인스턴스를 백업하는 경우 제외 옵션을 사용하지 마십시오  .

3. Crucible 중지

터미널에서 디렉토리를로 변경하고 다음  <Crucible home directory> 을 실행합니다.

bin/stop.sh

4. Crucible 설치

이 업데이트 프로세스는  전체 업그레이드를 수행 하지  않지만 새로운 버전의 Crucible을 새로운 설치 디렉터리에 설치합니다. 새로운 Crucible은 기존 Crucible 홈 디렉토리와 외부 데이터베이스를 사용합니다.

Crucible zip 파일을 다운로드  하십시오 . Windows의 경우, 설치 프로그램을 다운로드하십시오  . 참조  리눅스와 Mac에서 Crucible를 설치  또는  Windows에서 Crucible를 설치  자세한 설치 지침.


'includeplus'매크로 렌더링 오류 : CRUCIBLE과 FISHEYE 사이의 연결이 더 이상 존재하지 않습니다.


5. 사용자 지정 구성 업데이트

Crucible의 새 vesion이 설치되면 Crucible의 새 버전 (예 : SQL 드라이버 및 wrapper.config 파일)의 사용자 지정 구성을 업데이트해야합니다.

MySQL을 사용하고 있다면 JDBC 드라이버 에 대해 읽어보십시오  .

현재 Crucible을 Windows 서비스로 실행하고 Crucible의 새 버전을 새 위치에 설치하는 경우 Crucible을 제거한 다음 Windows 서비스로 다시 설치해야합니다. 자세한 내용 은 Windows  에서 Fisheye 업그레이드를참조하십시오  .

들어 Crucible 이후 3.4, Windows에서, 당신은 다운로드에 포함 된 도구를 사용하여 자바 VM의 속성을 편집 할 수 있습니다. JVM 시스템 특성을 참조하십시오 .


6. Crucible 시작

터미널에서 디렉토리를로 변경하고 다음   을 실행합니다.<Crucible home directory>

bin/start.sh

잠시 후, 동일한 시스템에 웹 브라우저에서, 이동  http://localhost:8060/ (다른 시스템 입력에서, 또는    설치 한 시스템의 이름입니다 Crucible ). http://hostname:8060/ hostname


버전 별 업데이트 정보

이 섹션에서는 각 버전의 Crucible에 대한 특정 업데이트 참고 사항을 제공합니다. 이 노트는 위의 기본 업데이트 가이드를 보완합니다.

Crucible의 현재 버전과 업그레이드 할 버전 사이의 각 버전에 대한 관련 섹션을 읽어야합니다.




Crucible 4.7 업그레이드 노트

Git과 Mercurial의 몇 가지 오래된 버전의 데이터베이스는 더 이상 사용되지 않습니다. Crucible 4.7에서 계속 지원되지만 업그레이드를 권장합니다. 자세한 내용 은 플랫폼 공지  사항의 끝 부분을 참조  하십시오.

32 비트 Windows에서 Fisheye를 호스트하는 경우 Crucible 4.7이 32 비트 설치 프로그램의 마지막 버전이므로 64 비트 버전으로 마이그레이션하는 것이 좋습니다.

MySQL 데이터베이스로 Fisheye를 실행하는 경우   전체 UTF8 문자 집합을 지원하려면 UTF8MB4 인코딩 으로 마이그레이션하는 것이 좋습니다 .

타사 플러그인이 설치되어있는 경우 Crucible 4.7과의 호환성을 확인하십시오. Jetty 서버가 업그레이드되면서 (Jetty 변경은 주로 JSP 파일에 영향을줍니다). HTTP PUT 메소드는 JSP 파일에 허용되지 않습니다. 대신 POST를 사용하십시오. HTTP GET은 'Content-encoding'속성을 사용하지 않아야합니다.

Crucible 4.6 업그레이드 노트

새 JVM 등록 정보

인 메모리 비난 캐시를 제어하는 ​​두 가지 새로운 속성이 추가되었습니다.

REST API 변경

모든 리뷰 관련 엔드 포인트 (예 : / rest-service / reviews-v1,  / rest-service / search-v1 또는 / rest-service-fecru / recently-visited-v1)는 여러 발행 키를 처리 할 수 ​​있습니다. <linkedIssues>는 문제를 연결하는 새로운 속성입니다. <jiraIssueKey>는 GET에서 <linkedIssues> 목록의 첫 번째 문제 (알파벳순)를 반환하고 POST에서는 문제를 리뷰와 연결합니다. 

자바 API 변경

ReviewData (문자열, 문자열, 문자열, UserData를, UserData를, UserData를, 문자열, 문자열, ReviewData $ 상태, 부울, PermId, 날짜, 날짜, 날짜, INT, 문자열)  제거되었습니다

ReviewData (문자열, 문자열, 문자열, UserData를, UserData를, UserData를, 문자열, 문자열, ReviewData $ 주, ReviewData $ ReviewType는 부울, PermId, 날짜, 날짜, 날짜, INT, 문자열)  제거되었습니다

com.atlassian.fisheye.plugin.web.helpers.Helper # getLinkedIssue  메소드가 추가되었습니다.

 닫기 검토 대화 상자에서 getWebPanelsForIssueInReview (HttpServletRequest, HttpServletResponse, String, String, String) 가 문제 전이를 처리하기 위해 추가되었습니다. 플러그인에서 ' crucible.review.complete.dialog.jira.action'또는 ' crucible.review.close .dialog.jira.action 'webPanelKey 그러면 업데이트가 필요합니다.

Mercurial 4.5 및 Git 2.16-2.18이 지원됩니다.

Crucible 4.6은 Mercurial 4.5 버전까지, Git 2.18 버전까지 지원합니다.

(warning) Git 2.16.x는 6.8보다 오래된 OpenSSH와 호환되지 않으며, FE-7016 에서 더 자세한 내용을 제공  합니다.

Crucible 4.4 업그레이드 노트

또한 참조하십시오 :


Mercurial 4.1 및 Git 2.12가 지원됩니다.

Crucible 4.4는 Mercurial 4.1 및 Git 2.12 클라이언트를 지원합니다

Mercurial 1.5 - 1.8.4는 더 이상 지원되지 않습니다.

Crucible 4.4부터 지원되는 가장 오래된 Mercurial 버전은 1.9.3 (2011 년 출시)입니다. Crucible 4.4로 업그레이드하기 전에 Mercurial 클라이언트 바이너리를 업그레이드하십시오.

Crucbile 4.4의 알려진 문제점

  


Crucible 4.2 업그레이드 노트

또한 참조하십시오 :

저장소 이름 바꾸기 지원

Crucible 4.2 및 이후 버전에서 각 저장소는 이제 (표시) 이름과 키로 식별됩니다. 키는 절대로 변경 될 수 없지만 기존 리포지토리의 경우에도 이름을 변경할 수 있습니다. 이전에는 리포지토리가 불변의 'name'속성 (Crucible 4.2의 'key'속성과 동일)에 의해서만 식별되었습니다. 자세한 내용  은 저장소 이름 바꾸기  를 참조하십시오.

Crucible 4.2로 업그레이드 할 때 각 저장소의 '이름'이 (표시) 이름과 키를 채우는 데 사용됩니다.

Crucible 4.2의 알려진 문제점



개요만들어진업데이트 됨정당한양수인보고자지위해결


문제 없음




Crucible 4.1 업그레이드 노트

또한 참조하십시오 :

Subversion 1.9가 지원됩니다.

Crucible 4.1  은이 버전에서 도입 된 Subversion 1.9와 새로운 FSFS 형식 7을 지원합니다  . Crucible에 새로운 Subversion 1.9 리포지토리를 추가하고 이미 추가 한 저장소 ( 'svnadmin upgrade'명령 사용)를 업그레이드 할 수 있습니다. Subversion 1.9 지원은 번들로 제공되는 SVN 클라이언트 (SVNKit)와  Subversion 1.9 기본 라이브러리  설정을 모두 포함합니다.

그러나 내부 성능 테스트 중에는  SVN 1.9 (FSFS 형식 7) 리포지토리에 번들 된 SVN 클라이언트를 사용하여 file : // 프로토콜을 사용하여 액세스 할 때 인덱싱 속도가 느려지 는 것을 관찰했습니다  (SVN 1.8과 비교). 따라서 인덱싱 시간이 우선 순위 인 경우 가능한 경우 SVN 1.5 - 1.8 저장소를 계속 사용하는 것이 좋습니다. 

Subversion 1.1 - 1.4는 더 이상 지원되지 않습니다.

Crucible 4.1부터 지원되는 가장 오래된 Subversion 버전은 1.5입니다 (2008 년 출시). 지원되는 형식은 형식 5와 FSFS 형식 3입니다. 그러므로 Crucible 4.1로 업그레이드하기 전에 'svn upgrade'명령을 사용하여 Subversion 클라이언트 및 서버 바이너리와 리포지토리를 모두 업그레이드하십시오 ). 

Subversion 병합이 지원됩니다.

Crucible 4.1은 Subversion에서 병합 작업을 지원합니다. Subversion의 분기를 병합하고 커밋 그래프 및 변경 집합 페이지에서 이에 대한 정보를 볼 수 있습니다. 자세한 내용은  공식 문서 페이지를 참조하십시오 .

병합 정보는 새로운 변경 집합에 대해서만 처리됩니다. 저장소 기록은 이전 변경 집합의 병합 정보를 노출하기 위해 다시 검색되지 않지만 이러한 기록 정보가 필요한 경우 전체 저장소 다시 색인을 수행 할 수 있습니다.

Crucible 4.1의 알려진 문제점



개요만들어진업데이트 됨정당한양수인보고자지위해결


문제 없음




Crucible 4.0 업그레이드 노트

또한 참조하십시오 :

사용자 디렉토리 마이그레이션

Crucible 4.0에는 새로운 사용자 디렉토리 관리가 포함되어 있습니다. 를 참조하십시오  어안 4.0 사용자 디렉토리 마이그레이션  사용자 관련 설정을 마이그레이션하는 방법에 대한 자세한 내용은.

플러그인 개발자를위한 API 변경 사항

플러그인 개발자가 아닌 경우이 섹션에서 설명한 변경 사항은 영향을 미치지 않습니다.

플러그인 시스템 4.0 업그레이드

Crucible 4.0에는 업그레이드 된 플러그인 시스템이 함께 제공됩니다. 업그레이드  로 인한 변경 사항에 대한 자세한 목록은 Atlassian Plugins 4.0 Upgrade Guide  참조하십시오  .

Crucible API 변경

Crucible 4.0의 Crucible API 변경 사항은 주로 사용자 디렉토리의 도입과 관련이 있습니다. 호스트 기반 인증이 제거되었으며 LDAP 기반 인증은 이제 Crucible에서 직접 처리하지 않고 Crowd에서 처리하므로 HostAuthSettings  및  LdapAuthSettings  클래스 가 제거되었습니다  .  절대적으로 필요한 경우 Crucible에 대한 사용자 정의 인증 자 또는 Crowd에 대한 사용자 정의 디렉토리 커넥터  구현할 수  있지만 기존 인증 방법에 의존 할 것을 강력히 권장합니다.

UserService #  getActiveUserCount의  사용 - 방법은 사용되지 않습니다  getLicensedUserCount을  대신.

 이 메소드가 제거되었으므로 더 이상 UserService #  setCrucibleEnabledForUsers  호출 하여 특정 사용자에 대해 Crucible 액세스를 사용할 수 없습니다  . 대신 사용자를 적절한 그룹에 할당하고 새  GlobalPermissionService # setPermissionsForGroup 메소드를 사용하여 그룹 권한을 설정해야합니다 .

REST API에는 사용자 및 그룹 관리와 관련된 사소한 변경 사항이 있습니다. 자세한 내용은  설명서  를 참조하십시오.

호스트 기반 인증 삭제 

이미 발표 된 바와 같이 Crucible 4.0 및 이후 버전에서는 호스트 기반 인증이 더 이상 지원되지 않습니다.

Crucible 4.0의 알려진 문제점



개요만들어진업데이트 됨정당한양수인보고자지위해결


문제 없음




Crucible 3.10 업그레이드 노트

또한 참조하십시오 :


자체 서명 인증서를 사용하는 보안 연결이 실패 할 수 있음

Crucible 3.10 commons-httpclient 은 SNI (Server Name Indication) 지원을 제공 하는 업데이트 된 버전을 사용합니다  . 그러나이 버전  commons-httpclient 에서는 더 엄격한 도메인 이름 확인   을 사용하므로 보안 연결을 사용하는 웹 훅 및 응용 프로그램 링크가 작동하지 않을 수 있습니다. 이는 Crucible이 응용 프로그램 도메인 이름 (예 : 'jira.company.com')이 인증서 일반 이름 (예 : '')과 일치하지 않는 자체 서명 인증서로 보안 연결을 사용하여 응용 프로그램에 액세스 할 때만 발생합니다. company.com ').

Crucible 3.10과 다른 응용 프로그램 간의 보안 연결에 사용하는 SSL 인증서를 업데이트해야 할 수도 있습니다. 자체 서명 된 인증서는 이전과 같이 더 이상 작동하지 않을 수 있습니다.


대문자 프로젝트 키 업그레이드 작업

프로젝트 키 업그레이드 작업은 Crucible 3.10으로 업그레이드 한 후 시작할 때 실행됩니다. 실행하는데 몇 초 밖에 걸리지 않습니다.

Crucible 3.10에서는 이제 대문자 프로젝트 키만 허용되므로이 작업 이 필요  합니다. DB 프로젝트 키 열을 적절하게 인덱싱 할 수 있도록이 변경 작업을 수행하여 다양한 메서드 호출에 대해 훨씬 향상된 성능을 제공합니다.

  • 모든 기존 프로젝트 키는 모두 대문자로 변환됩니다. Crucible의 경우 검토 키의 프로젝트 핵심 부분도 포함됩니다. 
  • 프로젝트 키 충돌이 발생하면  접미어 를 추가하여 프로젝트 키의 이름이 바뀝니다  UPGRADE[Number] .  필요한 경우 업그레이드 후에 이름이 바뀐 프로젝트 키를 수동으로 변경할 수 있습니다 .
  • 업그레이드 작업은 프로젝트 키 변경에 대한 로그를 생성합니다. 로 시작하는 로그 찾기 [projectKey.uppercase] 
  • 모든  인수로 프로젝트 키를 사용하여 작업은 대소 문자를 구별  제외  v에 자동으로 브라우저에서 iew 작업을있는 경우를 구분과 의지 대문자 프로젝트 키를 누릅니다.
  • Fisheye 및 Crucible 트랙은 최근 모든 사용자의 프로젝트, 리뷰 및 스 니펫을 방문했습니다. 그러나 이름이 변경된 프로젝트 키가있는 프로젝트, 리뷰 및 스 니펫은 최근에 방문한 캐시에는 나타나지 않습니다. 

Jira Software와 Crucible 프로젝트 사이에 엔티티 링크가 있으면 매핑이 자동으로 업데이트됩니다. 방문하여 확인할 수 있습니다.

관리  > 부가 기능 > 어안 (어안) 설정 > 지라의 어안 / Crucible 엔티티 매핑  . Crucible 프로젝트가 모두 대문자로되어 있지 않으면 캐시 새로 고침을 클릭 하여 매핑을 업데이트하십시오. 

업그레이드 작업 중 잠재적 인 데이터 손상을 피하기 위해 DB가 UTF-8 기본 인코딩으로 대소 문자를 구분하지 않으면 Crucible은 시작을 거부합니다. 이 경우 다음 로그 메시지가 표시됩니다.

FeCru connecting to DB not using case-sensitive UTF8 encoding


LDAP 동기화

Crucible 3.10은 이제   LDAP 서버에서 데이터를 요청할 때 페이징  (기본 페이지 크기가 1000)을 지원하며 Active Directory에서 사용자 계정 수가 1000을 초과 할 때 원활하게 작동합니다.  그것은  LDAPv3의를 지원하지 않는 서버로 이전 동작으로 되돌아갑니다.

페이징 크기는 fisheye.ldap.sync.page.size 시스템 특성 으로 제어 할 수 있습니다  . 이 값을 0으로 설정하면 페이징이 비활성화됩니다.

Crucible 3.10의 알려진 문제점



개요지위


문제 없음




Crucible 3.9 업그레이드 노트

또한 참조하십시오 :

Lucene 색인 업그레이드 작업

Lucene 색인의 색인은 Crucible 3.9로 업그레이드 한 후 시작할 때 실행됩니다. 이는 검토 열 ( CRUC-6560  -  Review 대시 보드는 검토 키 CLOSED로 정렬 할 수 없음  )에 의한 검토 정렬을 가능하게하기 위해 Lucene 색인에 n 필드 가 추가 되었기 때문에 필요합니다 .    

15000 리뷰를 위해 다시 색인화하는 데 약 10 분이 소요됩니다. 다시 색인하는 동안 Crucible은 사용할 수 있지만 일부 리뷰는 표시되지 않을 수 있습니다.

스마트 커밋은 이제 Jira REST API를 사용합니다.

버전 3.9.0부터 Crucible은  Jira Smart Commits 용 Jira Fisheye Plugin 대신 Jira REST API  사용합니다  . 이 변경으로 Jira의 향후 버전에서 스마트 커밋을 사용할 수 있습니다. Crucible의 이전 버전 (3.9.0 이전)과 Jira 7에서 스마트 커밋을 사용하면 이메일을 통해 오류 알림이 발생합니다. 

힘내 클론 변경

버전 3.9.0부터 Crucible은 gc.pruneExpire=never 참조를 추가하여 저장소를 복제 할 때 Git 가비지 콜렉션을 해제하여  참조되지 않은 객체가 로컬 복제본에서 제거되지 않도록합니다. 또한, 저장소를 복제 할 때  git config  는 인스턴스 시작 중에 각 저장소에서 실행됩니다. 이 변경은 Git 캐시 버전 ( CACHE_VERSION 22)에 충돌합니다  .

지원되는 플랫폼 업그레이드

  • 이제 Oracle 12c가 지원됩니다.
  • Git 2.4.6과 Mercurial 3.4.2가 지원된다.
  • Java 7에 대한 지원은 이전에 발표 된 Crucible 3.9에서 제거되었습니다  .
  • Internet Explorer 9에 대한 지원은 이전에 발표 된 Crucible 3.9에서 제거되었습니다  .

Crucible 3.9의 알려진 문제점



개요지위


문제 없음




Crucible 3.8 업그레이드 노트

또한 참조하십시오 :

새 데이터베이스 인덱스를 사용하여 검토 대시 보드 및 검토 검색 페이지 로딩 시간 개선

시작시 데이터베이스 인덱스를 추가하는 데이터베이스 업그레이드 작업이 실행됩니다. 이 작업은 몇 분 정도 소요되며 대부분의 경우 몇 초 내에 완료해야합니다.

새로 생성 된 브랜치의 Git 인덱싱 시간 향상

Git 인덱싱을 빠르게하기 위해 내부 저장소 캐시에 새로운 필드가 추가되었습니다. 업그레이드 후 저장소를 처음 시작할 때 각 Git 저장소의 캐시가 자동으로 업그레이드됩니다. 저장소 당 분이 소요될 것으로 예상  되지만 저장소에 수천 개의 지점이있는 경우 약간 더 오래 걸릴 수 있습니다.

지원되는 플랫폼 업그레이드

Crucible 3.8의 알려진 문제점



개요지위


문제 없음




Crucible 3.7 업그레이드 노트

또한 참조하십시오 :

지원되는 플랫폼 업그레이드

Crucible 3.7의 알려진 문제점



개요지위


문제 없음




Crucible 3.6 업그레이드 노트

또한 참조하십시오 :

지원되는 플랫폼 업그레이드

SSLv3 지원은 기본적으로 사용되지 않습니다.

Crucible 3.6에서 SSLv3 지원은 기본적으로 사용되지 않습니다. 이는 지원되는 브라우저의 정상적인 작동에는 영향을 미치지 않습니다. SSLv3 지원을 다시 활성화해야하는 경우 Jetty 용 SSL 암호 그룹 구성을 참조하십시오  .

Crucible 3.6의 알려진 문제점



개요지위


문제 없음




Crucible 3.5 업그레이드 노트

Crucible 3.5.0 이전 버전에서 Universal Plugin Manager 플러그인을 Crucible 3.5.0과 함께 제공되는 것보다 새로운 버전으로 업그레이드하면 문제가 발생할 수 있습니다.

이에 대한 일시적인 해결책은 Universal Plugin Manager 플러그인의 사용자 정의 설치 버전을 제거하는 것입니다.

3.4.5에서 3.5.0으로 업그레이드 한 후 일부 페이지에 액세스하려고하면이 오류가 웹 브라우저에 인쇄됩니다.

javax.servlet.jsp.JspException: javax.el.ELException: java.lang.NullPointerException: couldn't locate WebResourceIntegration service

해결 방법 :

  • 새로운 Crucible 인스턴스를 중지하십시오.
  • $ FISHEYE_INST / var / plugins / user / plugin.xxxxxx.atlassian-universal-plugin-manager-plugin * .jar에서 Universal Plugin Manager Plugin의 새 버전을 제거하십시오.
  • 새로운 Crucible 인스턴스를 다시 시작하십시오.

또한 참조하십시오 :

Crucible 3.5의 알려진 문제점



개요지위


문제 없음




Crucible 3.4 업그레이드 노트

또한 참조하십시오 :

Windows 설치 프로그램

우리는 Crucible on Windows 용 32 비트 및 64 비트 설치 프로그램을 제작했습니다. 각 설치 관리자는 Crucible을 Windows 서비스로 추가하고 자동으로 서비스를 시작합니다. 빠른 설치는 기본적으로  Data 디렉토리와 별도의 설치 디렉토리를  C:\Atlassian만듭니다. 사용자 정의 설치 모드를 사용하면 설치 Data 디렉토리에 다른 Data 디렉토리를 포함하지 않아도되므로 설치 및 디렉토리  의 다른 위치를 선택할 수 있습니다  . 설치 관리자는 FISHEYE_INST시스템 환경 변수를 작성합니다 .

자세한 설치 지침 은 Windows  Crucible 설치를 참조하십시오  .

Crucible 설치 프로그램을 여기에서 다운로드  하십시오 .

Crucible은 이제 Windows에서 다른 IP 주소에 바인딩 할 수 있습니다.

Crucible 3.4 이전의 Crucible 버그 (  FE-4909 CLOSED  )는 Crucible이 사용자가 구성한 IP 주소에 올바르게 바인딩되지 않았을 수 있음을 의미합니다. Crucible이 여러 IP 주소를 가진 네트워크 인터페이스의 단일 IP 주소에 바인드되도록 구성한 경우 이런 일이 발생할 수 있습니다. Crucible은 사실 다른 IP 주소에 바인딩되어있을 수 있습니다. 예를 들어, IP 주소가 1.2.3.4 및 1.2.3.5 인 인터페이스가 있고 Crucible에서 1.2.3.5를 사용하도록 구성한 경우 1.2.3.4에 잘못 바인딩되었을 수 있습니다.  

이제 버그가 수정되어 Crucible 3.4 및 이후 버전이 이제 이전에 바인딩 된 주소와 다를 수 있지만 구성된 IP 주소에 올바르게 바인딩됩니다.

v1 REST API 리소스가 사용되지 않음

'v1'REST API 리소스는 향후 제공되지 않을 예정이며 이후 릴리스에서 제거됩니다. Fisheye Crucible REST API를 참조하십시오  .

Crucible 3.4의 알려진 문제점



개요지위


문제 없음




Crucible 3.3 업그레이드 노트

 위  업그레이드 단계 섹션 도 참조하십시오  .

이전에 발표 된대로 Crucible 3.3에서는 다음 플랫폼을 더 이상 지원하지 않습니다.

  • Internet Explorer 8
  • MySQL 5.0
  • PostgreSQL 8.2
  • SQL Server 2005

Crucible에 대한 End of Support Announcements를 읽으십시오  .

지원되는 플랫폼 업그레이드

  • SVN 1.8은 Crucible 3.3에서 지원됩니다.
  • Microsoft Internet Explorer 11은 Crucible 3.3에서 지원됩니다.

Crucible Supported platforms을 참조하십시오  .

Crucible 3.3의 알려진 문제점



개요지위


문제 없음




Crucible 3.2 업그레이드 노트

 위  업그레이드 단계 섹션을 참조하고  Crucible에 대한 지원 종료 알림  페이지  읽어보십시오  .

Crucible 3.2의 다음 변경 사항에 유의하십시오.

REST 엔드 포인트 변경

Crucible 3.2의 경우 RestReviewService.remindIncompleteReviewers () ( '/ rest-service / reviews-v1 / {reviewId} / remind') 끝점이 'application / x-www-form-urlencoded'콘텐츠 유형을 'message' '및'recipient '매개 변수를 'message / '및'recipients 'JSON 필드 가있는  'application / json '콘텐츠 유형으로 변경합니다. https://docs.atlassian.com/fisheye-crucible/latest/wadl/crucible.html#d2e1881을 참조  하십시오 .

사용자 데이터가 data0.bin에서 SQL 데이터베이스로 이동되었습니다.

업그레이드 작업은 사용자 데이터를 SQL 데이터베이스로 이동시키는 시작시 실행됩니다. 우리는 데이터 손상이나 손실 위험을 줄이기 위해이 작업을 수행하고 있습니다.

XSRF 보호

Crucible 3.2.0은 XSRF 공격으로부터 보호합니다.

LightSCM 플러그인을 구현 SimpleConfigurationServlet하고 scmutils라이브러리에 제공된 기본 클래스를 사용한 경우 GET이 아닌 HTTP POST를 사용하여 '삭제'작업을 수행하도록 관리 페이지를 수정해야합니다.

Crucible에서 런타임시에 "anchor-post"클래스를 제공하여 앵커 태그를 POST로 변환하도록 할 수 있습니다. 예를 들어, 앵커 :

<a class="anchor-post" href="#" data-href="./fsscm?name=TEST&delete=true">Delete</a>

양식 매개 변수 name = TEST 및 delete = true를 사용하여 ./fsscm에 POST하는 양식으로 변환됩니다.

내부 관리되는 Git 저장소가 더 이상 지원되지 않습니다.

이전에 발표 된 것처럼  내부적으로 관리되는 Git 저장소는 Crucible 3.2에서 더 이상 지원되지 않습니다.

 내부 관리되는 Git 저장소 마이그레이션 옵션 및 절차에 대한 정보 는  마이그레이션 가이드 를 참조하십시오. 내부적으로 관리되는 저장소를 마이그레이션하기 전에 Crucible 3.2로 업그레이드하는 것이 좋습니다.

지원되는 플랫폼 업그레이드

Crucible Supported platforms을 참조하십시오  .

Crucible 3.2의 알려진 문제점



개요지위


문제 없음




Crucible 3.1 업그레이드 노트

 위  업그레이드 단계 섹션을 참조하고  Crucible에 대한 지원 종료 알림 페이지  읽어보십시오  .

Crucible 3.1의 다음 변경 사항에 유의하십시오.

Crucible 3.1 일부 저장소 별 Lucene 색인을 전역 저장소 간 Lucene 색인으로 병합

Crucible 3.1은 QuickSearch 및 QuickNav의 성능과 확장 성을 크게 향상 시켰습니다. 이를 달성하기 위해 저장소 별 'METADATA'Lucene 색인을 단일 글로벌 저장소 저장소 Lucene 색인으로 이동합니다. 즉, Crucible은 이전 N 대신 단일 검색 인덱스 만 쿼리하면되므로 더 적은 시간에 더 많은 리포지토리를 검색 할 수 있습니다. 이러한 인덱스를 단일 크로스 리포지토리 인덱스에 병합하는 것은 다음 두 가지 방법으로 새로 고칠 수 있습니다.

  1. 권장 사항 : Crucible 3.1을 처음 실행할 때 자동으로 실행되는 업그레이드 작업입니다.
  2. 별도의 준비 서버에서 오프라인 프로세스로.

자동 업 그레 이드 작업 중 Crucible은 파일, 커밋 및 커미터에 대한 검색 결과가 불완전 할 수 있지만 완전히 유용하고 기능적입니다.

우리의 테스트에서 우리는 자동 업그레이드 작업이 다른 종류의 144 개의 저장소와 FISHEYE_INST 폴더 (로그 제외)에 58GB의 데이터가있는 Crucible 인스턴스를 완료하는 데 4 시간이 걸렸습니다. 우리는 자동 업그레이드 작업이 대부분의 생산 Crucible 설치에 적합하다고 확신합니다. 이 시간 동안 빠른 탐색 및 빠른 검색을 제외하고 인스턴스가 완전히 기능적 이었음을 반복 할 가치가 있습니다 (검토, Jira 통합, 활동 스트림, 차트 등).

그럼에도 불구하고, 필요  에 따라 별도의 준비 서버에서 오프라인 프로세스로 다시 인덱싱을 수행 하기위한 지침을 제공  합니다.

플러그인 설정이 config.xml에서 SQL 데이터베이스로 이동합니다.

Crucible 3.1.0부터 config.xml의 <properties> 요소에 저장되어 있던 플러그인 설정이 SQL 데이터베이스에 저장됩니다. 여기에는 ApplicationLinks, UniversalPluginManager 등의 모든 번들 플러그인 및 타사 플러그인에 대한 설정이 포함됩니다. 

시작시 업그레이드 작업이 실행되며 config.xml에있는 모든 속성이 SQL 데이터베이스의 새 테이블에 삽입됩니다. 성공하면 config.xml에서 속성이 제거됩니다. 

이 변경의 일부로 RepositoryOptions.setProperties (Map <String, String> 속성) 및 RepositoryOptions.getProperties () 메소드가 API에서 제거되었습니다. 이러한 방법 중 하나를 사용하는 플러그인을 사용하는 경우 플러그인을 Spring 구성 요소 PluginSettingsFactory를 사용하는 버전으로 업데이트해야합니다. 플러그인은 이전 RepositoryOptions API를 통해 이전에 사용 가능했던 마이그레이션 된 전역 및 저장소 별 특성에 액세스 할 때이를 사용할 수 있습니다. 

Crucible 3.1의 알려진 문제점



개요지위


문제 없음




Crucible 3.0 업그레이드 노트

  업그레이드 단계 섹션 도 참조하십시오 .

Crucible 3.0의 다음 변경 사항에 유의하십시오.

부두 8

Crucible 3.0은 이제 Jetty 8을 웹 서버 및 Java 서브렛 컨테이너로 사용합니다. 이 변경 사항은 Crucible 3.0으로 업그레이드 할 때 완전히 투명해야합니다. 그러나 jetty-web.xml 파일 또는 maxFormContentSize 시스템 특성 을 사용자 정의한 경우 , 새 버전 의  파일이나  특성 을 갱신해야합니다. 자세한 내용  은 Fisheye  및이  Fisheye KB 페이지 에서 액세스 로깅 활성화  를 참조하십시오.

무한대 DB

Crucible 3.0은 내부적으로 InfinityDB 3.0 데이터베이스를 사용하여 Crucible에 대한 동시 액세스 성능을 향상시킵니다 . 이러한 변화는 모든면에서 사용자에게 투명합니다.

파이프 라인 인덱싱

Crucible 3.0은 저장소 인덱싱 프로세스를 단계별 및 동시 방식으로 수행 할 수있는 별도의 작업으로 분할하는 새로운 인덱싱 방식을 도입했습니다. 사용자는 색인 작성이 진행됨에 따라 검토 작성과 같은 Crucible 기능을 사용할 수있게됩니다. 이 변경 사항은 다른 모든 측면에서 사용자에게 투명합니다. 파이프 라인 색인 생성을  참조하십시오  .

세션 쿠키로 사용자 환경 설정 처리 개선 

업그레이드하면 일부 사용자의 선호도가 떨어질 수 있습니다.

SQL Server 트랜잭션 격리 구성

SQL Server가 트랜잭션 격리 수준에 대해 스냅 숏 모드를 사용하도록 구성을 변경하는 것이 좋습니다 (SQL Server 로의 마이그레이션 참조)  . 이 변경으로 인해 때때로 데이터베이스 교착 상태가 방지되고 로그 및 관리자 화면의 성능 경고 메시지가 표시되지 않습니다.

Crucible 3.0의 알려진 문제점



개요지위


문제 없음





알려진 문제점 확인 및 Crucible 업그레이드 문제 해결

Crucible 설치를 업그레이드하기 위해 위의 단계를 완료 한 후에 무언가가 올바르게 작동하지 않는 경우 알려진 Crucible 문제가 있는지 확인하고 아래에 설명 된대로 업그레이드 문제를 해결하십시오.

  • 알려진 문제가 있는지 확인하십시오 . 때로는 소프트웨어를 출시 한 후 Crucible 최신 버전의 문제점을 발견 할 수 있습니다. 이러한 경우 Crucible 지식 기반에 알려진 문제점에 대한 정보를 게시합니다.  Crucible Knowledge Base에서 Fisheye 및 Crucible의 알려진 문제점  확인하고  필요할 경우 지침에 따라 필요한 패치를 적용하십시오.
  • Crucible 업그레이드 중에 문제가 발생 했습니까?  Crucible 기술 자료에서 문제 해결 업그레이드  가이드를 참조하십시오  .
  • 업그레이드 도중 문제가 발생하여 해결할 수없는 경우 지원 티켓을 만드   십시오. 지원 엔지니어 중 한 명이 도와드립니다.


2019 년 3 월 19 일에 최종 수정 됨

  • No labels